Moodle 2.7 or later requires at least PHP 5.4.4 (currently using version 5.3.28-nmm1).
Please upgrade your server software or install older Moodle version.